You are here: Known Vulnerabilities in Mozilla Products (Thunderbird 2.0.0.4) > MFSA 2007-15

Mozilla Foundation Security Advisory 2007-15

Title: Security Vulnerability in APOP Authentication
Impact: Moderate
Announced: May 30, 2007
Reporter: Gaëtan Leurent
Products: Thunderbird, SeaMonkey

Fixed in: Thunderbird 1.5.0.12
  Thunderbird 2.0.0.4
  SeaMonkey 1.0.9
  SeaMonkey 1.1.2

Description

Gaëtan Leurent informed us of a weakness in APOP authentication that could allow an attacker to recover the first part of your mail password if the attacker could interpose a malicious mail server on your network masquerading as your legitimate mail server. With normal settings it could take several hours for the attacker to gather enough data to recover just a few characters of the password. This result was presented at the Fast Software Encryption 2007 conference.

In a rump session at the same conference a team from The University of Electro-Communications claimed that a variant on the same hash-collision attack allowed them to recover a 31 character password.

Fixed versions of Thunderbird and SeaMonkey mail prevent this technique by stricter enforcement of the Message-ID format used by APOP.

POP mail accounts which do not use any authentication are common and in the same hypothetical situation the password could be recovered immediately without any special programming on the attacker's part.

Workaround

Upgrade to a fixed version of the client if your mail account uses APOP authentication.

References