Your system may not meet the requirements for Firefox, but you can try one of these versions:

Your system doesn't meet the requirements to run Firefox.

Your system doesn't meet the requirements to run Firefox.

Please follow these instructions to install Firefox.

Firefox Privacy Notice

Mozilla Foundation Security Advisory 2016-22

Service Worker Manager out-of-bounds read in Service Worker Manager

Announced
March 8, 2016
Reporter
Looben Yang
Impact
Critical
Products
Firefox
Fixed in
  • Firefox 45

Description

Security researcher Looben Yang reported a mechanism where the Clients API in Service Workers can be used to trigger an out-of-bounds read in ServiceWorkerManager. This results in a potentially exploitable crash.

References