Mozilla

Mozilla Foundation Security Advisory 2013-56

PreserveWrapper has inconsistent behavior

Announced
June 25, 2013
Reporter
Boris Zbarsky
Impact
High
Products
Firefox, Firefox ESR, SeaMonkey, Thunderbird, Thunderbird ESR
Fixed in
  • Firefox 22
  • Firefox ESR 17.0.7
  • SeaMonkey 2.19
  • Thunderbird 17.0.7
  • Thunderbird ESR 17.0.7

Description

Mozilla developer Boris Zbarsky found that when PreserveWrapper was used in cases where a wrapper is not set, the preserved-wrapper flag on the wrapper cache is cleared. This could potentially lead to an exploitable crash.

In general these flaws cannot be exploited through email in the Thunderbird and SeaMonkey products because scripting is disabled, but are potentially a risk in browser or browser-like contexts in those products.

References