Mozilla

Mozilla Foundation Security Advisory 2008-53

XSS and JavaScript privilege escalation via session restore

Announced
November 12, 2008
Reporter
David Bloom, moz_bug_r_a4
Impact
Critical
Products
Firefox
Fixed in
  • Firefox 2.0.0.18
  • Firefox 3.0.4

Description

Security researcher David Bloom reported that the browser's session restore feature can be used to violate the same-origin policy and run JavaScript in the context of another site. Any otherwise unexploitable crash can be used to force the user into the session restore state

Mozilla security researcher moz_bug_r_a4 demonstrated that this vulnerability could also be used by an attacker to run arbitrary JavaScript with chrome privileges.

Workaround

Disable JavaScript until a version containing these fixes can be installed.

References