Your system may not meet the requirements for Firefox, but you can try one of these versions:

Your system doesn't meet the requirements to run Firefox.

Your system doesn't meet the requirements to run Firefox.

Please follow these instructions to install Firefox.

Firefox Privacy Notice

Mozilla Foundation Security Advisory 2006-22

CSS Letter-Spacing Heap Overflow Vulnerability

Announced
April 13, 2006
Reporter
TippingPoint and the Zero Day Initiative
Impact
Critical
Products
Firefox, Mozilla Suite, SeaMonkey, Thunderbird
Fixed in
  • Firefox 1.0.8
  • Firefox 1.5.0.2
  • Mozilla Suite 1.7.13
  • SeaMonkey 1.0.1
  • Thunderbird 1.0.8
  • Thunderbird 1.5.0.2

Description

An anonymous researcher for TippingPoint and the Zero Day Initiative discovered an integer overflow triggered by the CSS letter-spacing property. This results in in under-allocating memory and ultimately a heap buffer overflow which could be exploited to run code of the attacker's choice.

The overflow condition itself does not require JavaScript and thus could affect Thunderbird via received mail, but without scripting to prepare memory it may not be possible to exploit this condition in mail.

Workaround

Upgrade to the fixed version.

References