Your system may not meet the requirements for Firefox, but you can try one of these versions:

Your system doesn't meet the requirements to run Firefox.

Your system doesn't meet the requirements to run Firefox.

Please follow these instructions to install Firefox.

Firefox Privacy Notice

Mozilla Foundation Security Advisory 2005-44

Privilege escalation via non-DOM property overrides

Announced
May 11, 2005
Reporter
moz_bug_r_a4
Impact
Critical
Products
Firefox, Mozilla Suite
Fixed in
  • Firefox 1.0.4
  • Mozilla Suite 1.7.8

Description

Additional checks were added to make sure Javascript eval and Script objects are run with the privileges of the context that created them, not the potentially elevated privilege of the context calling them in order to protect against an additional variant of MFSA 2005-41.

Workaround

Upgrade to Firefox 1.0.4 or Mozilla 1.7.8

References

Bug and exploit details withheld until May 18, 2005