Your system may not meet the requirements for Firefox, but you can try one of these versions:

Your system doesn't meet the requirements to run Firefox.

Your system doesn't meet the requirements to run Firefox.

Please follow these instructions to install Firefox.

Firefox Privacy Notice

Firefox

Firefox 2.0 System Requirements

Windows

Operating Systems
  • Windows 98
  • Windows 98 SE
  • Windows ME
  • Windows NT 4.0
  • Windows 2000
  • Windows XP
  • Windows Server 2003
  • Windows Vista
Minimum Hardware
  • Pentium 233 MHz (Recommended: Pentium 500MHz or greater)
  • 64 MB RAM (Recommended: 128 MB RAM or greater)
  • 52 MB hard drive space

Mac

Operating Systems
  • Mac OS X 10.2.x and later
Minimum Hardware
  • Macintosh computer with an Intel x86 or PowerPC G3, G4, or G5 processor
  • 128 MB RAM (Recommended: 256 MB RAM or greater)
  • 200 MB hard drive space

Linux

Software Requirements

Please note that Linux distributors may provide packages for your distribution which have different requirements.

  • Linux kernel - 2.2.14 with the following libraries or packages minimums:
    • glibc 2.3.2
    • gtk+2.0
    • XFree86-3.3.6
    • fontconfig (also known as xft)
    • libstdc++5
Minimum Hardware
  • Intel Pentium II or AMD K6-III+ 233 MHz CPU (Recommended: 500MHz or greater)
  • 64 MB RAM (Recommended: 128 MB RAM or greater)
  • 52 MB hard drive space