Firefox System Requirements

Firefox for Android Aurora 46.0a2

Android Honeycomb (version 3) will no longer be supported.