You are here: Known Vulnerabilities in Mozilla Products (Firefox 1.5.0.8) > MFSA 2006-65

Mozilla Foundation Security Advisory 2006-65

Title: Crashes with evidence of memory corruption (rv:1.8.0.8)
Impact: Critical
Announced: November 7, 2006
Reporter: Mozilla Developers
Products: Firefox, Thunderbird, SeaMonkey

Fixed in: Firefox 1.5.0.8
  Thunderbird 1.5.0.8
  SeaMonkey 1.0.6

Description

As part of the Firefox 1.5.0.8 release we fixed several bugs to improve the stability of the product. Some of these were crashes that showed evidence of memory corruption and we presume that at least some of these could be exploited to run arbitrary code with enough effort.

Thunderbird shares the browser engine with Firefox and could be vulnerable if JavaScript were to be enabled in mail. This is not the default setting and we strongly discourage users from running JavaScript in mail. Without further investigation we cannot rule out the possibility that for some of these an attacker might be able to prepare memory for exploitation through some means other than JavaScript, such as large images or plugin data.

The Firefox 2.0 release is not affected by these flaws; some of these affected pre-release versions and were fixed prior to final release.

Workaround

Upgrade to the fixed versions. Do not enable JavaScript in Thunderbird or the mail portions of SeaMonkey.

References

Jesse Ruderman and Martijn Wargers reported crashes in the layout engine

shutdown demonstrated that a crash in XML.prototype.hasOwnProperty was exploitable

Igor Bukanov and Jesse Ruderman reported potential memory corruption in the JavaScript engine