You are here: Security Center > Mozilla Foundation Security Advisories > MFSA 2010-02

Mozilla Foundation Security Advisory 2010-02

Title: Web Worker Array Handling Heap Corruption Vulnerability
Impact: Critical
Announced: February 17, 2010
Reporter: Orlando Barrera II
Products: Firefox, SeaMonkey

Fixed in: Firefox 3.6
  Firefox 3.5.8
  SeaMonkey 2.0.3

Description

Security researcher Orlando Barrera II of SecTheory reported, via TippingPoint's Zero Day Initiative, that Mozilla's implementation of Web Workers contained an error in its handling of array data types when processing posted messages. This error could be used by an attacker to corrupt heap memory and crash the browser, potentially running arbitrary code on a victim's computer.

Web Workers were introduced in Firefox 3.5; Firefox 3.0 and earlier versions were not affected.

Workaround

Disable JavaScript until a version containing these fixes can be installed.

References