You are here: Known Vulnerabilities in Mozilla Products (Firefox 1.5.0.7) > MFSA 2006-59

Mozilla Foundation Security Advisory 2006-59

Title: Concurrency-related vulnerability
Impact: Critical
Announced: September 14, 2006
Reporter: Jonathan Watt, Michal Zalewski
Products: Firefox, Thunderbird, SeaMonkey

Fixed in: Firefox 1.5.0.7
  Thunderbird 1.5.0.7
  SeaMonkey 1.0.5

Description

Jonathan Watt and Michal Zalewski independently reported timing dependent testcases that trigger crashes at the same place during text display. We have seen no demonstration that these crashes could be reliably exploited, but they do show evidence of memory corruption so we presume they could be.

Thunderbird shares the browser engine with Firefox and could be vulnerable if JavaScript were to be enabled in mail. This is not the default setting and we strongly discourage users from enabling JavaScript in mail.

Workaround

Disable JavaScript until you can upgrade to a fixed version. Do not enable JavaScript in mail clients such as Thunderbird.

References