You are here: Known Vulnerabilities in Mozilla Products (Firefox 1.5.0.5) > MFSA 2006-45

Mozilla Foundation Security Advisory 2006-45

Title: Javascript navigator Object Vulnerability
Impact: Critical
Announced: July 25, 2006
Reporter: TippingPoint and the Zero Day Initiative
Products: Firefox 1.5, SeaMonkey

Fixed in: Firefox 1.5.0.5
  SeaMonkey 1.0.3

Description

An anonymous researcher for TippingPoint and the Zero Day Initiative showed that when used in a web page Java would reference properties of the window.navigator object as it started up. If the page replaced the navigator object before starting Java then the browser would crash in a way that could be exploited to run native code supplied by the attacker.

Firefox 1.0 and Mozilla Suite 1.7 are not vulnerable.

Thunderbird does not load Java or other plugin content and is thus not vulnerable.

Workaround

Disable Java until you upgrade your browser to a version containing the fix.

References