You are here: Known Vulnerabilities in Mozilla Products (Firefox 1.0.4) > MFSA 2005-44

Mozilla Foundation Security Advisory 2005-44

Title: Privilege escalation via non-DOM property overrides
Severity: Critical
Reporter: moz_bug_r_a4
Products: Firefox, Mozilla Suite

Fixed in: Firefox 1.0.4
  Mozilla Suite 1.7.8

Description

Additional checks were added to make sure Javascript eval and Script objects are run with the privileges of the context that created them, not the potentially elevated privilege of the context calling them in order to protect against an additional variant of MFSA 2005-41.

Workaround

Upgrade to Firefox 1.0.4 or Mozilla 1.7.8

References

Bug and exploit details withheld until May 18, 2005